NanoVNA - wgranie nowego firmware'u (pod Windą) - Sterowniki trybu DFU

Spis treści

Instalacja sterowników trybu DFU

Kłopotliwy tryb DFUStandardowe podłączenie NanoVNA (w trybie normalnej pracy) do portu USB raczej nie nastręcza kłopotów. Winda prawidłowo rozpoznaje urządzenie, instaluje sterownik i w Menedżerze urządzeń pojawia się dedykowany port COM.

Inaczej gdy urządzenie pracuje w trybie DFU. I to czasami zaskakuje!

Jest ono prawidłowo rozpoznawane (identyfikator: STM32 Bootloader). Jednak sterowniki nie są instalowane automatycznie.

Odpowieni wpis lokowany jest w "Innych urządzeniach"! Ikona opatrzona markerem wskazuje, że urządzenie nie działa poprawnie!

Zautomatyzowane wyszukiwanie sterowników (w moim przypadku) rzadko dawało pozytywne wyniki. Potrzebujesz zatem instalatora sterowników właściwych dla użytkowanej wersji MS Windows (32b lub 64b).

Jest dobrze. STMicroelectronics w pakiecie, który już pobrałeś umieściła równie wymagane sterowniki (instalatory). Podczas instalacji nie jest wymagane podłączenie NanoVNA do komputera.Instalacja sterowników trybu DFU

W oknie lokalizacji: C:\Program Files (x86)\STMicroelectronics\Software\DfuSe v3.0.6\Driver zobaczysz listę obsługiwanych systemów Windows (7-10). Wybrałem: 10. W katalogu tym oprócz innych elementów znajduje się plik: dpinst_amd64.exe

Zawiera on instalator sterowników STM32,dedykowany dla Windowsów 64b.

Jeśli masz inną wersję Windowsów lub architekturę wybierz odpowiedni katalog i plik. Nawet jeśli sterowniki były już zainstalowane - instalator je "nadpisze". Nie pytając o zgodę! ;)

Jeśli teraz podłączymy do komputera NanoVNA ustawione w tryb DFU (u części użytkowników) pewne zaskoczenie powoduje fakt, że w (oczekiwanej) pozycji Menedżera urządzeń ("Porty (COM i LPT)") nie widać NanoVNA.

Bo jest ono w pozycji "Kontrolery uniwersalnej magistrali szeregowej" rozpoznane jako: "STM Device in DFU Mode"! Inne miejsce i inna nazwa urządzenia niektórych dezorientuje.

Jeśli NanoVNA (jako "STM Device in DFU Mode") tam nie ma - coś z instalacją poszło nie tak! Sprawdź połączenia, ewentualnie powtórz instalację sterowników.